Skip to content

Notes de version Canopsis 3.22.0

Information

Les prochaines versions de Canopsis ne seront prochainement plus compatibles avec Debian 8, sorti début 2015. Pensez à migrer vers un environnement supporté, tel que Debian 9, CentOS 7 ou encore une installation Docker.

Canopsis 3.22.0 a été publié le 28 juin 2019.

Procédure de mise à jour

Suivre la procédure standard de mise à jour de Canopsis.

Veuillez noter que la connexion CAS ne sera possible qu'en UIv3 à partir de cette version.

Il n'y a aucune autre action à réaliser pour mettre Canopsis à jour d'une version 3.21 à une version 3.22.

Changements entre Canopsis 3.21.0 et 3.22.0

Voir le ChangeLog complet pour plus de détails techniques.

  • Documentation :
    • Ajout de documentation sur le nouveau helper {{ internal-link }} (#1799)
    • Corrections diverses pour les cas d'utilisation de {{ entities name="" }} dans les widgets de Météo (!955)
  • Authentification :
    • Correction de la connexion CAS avec l'UIv3. Il n'est désormais plus possible d'utiliser une connexion CAS en UIv2 (#1796)
  • UI :
    • Bac à alarmes :
      • Correction de la largeur minimum nécessaire pour le Bac à alarmes, notamment lorsque celui-ci possède beaucoup de colonnes (#1782)
      • Correction de l'ouverture de la timeline du Bac à alarmes, qui pouvait parfois avoir des comportements incorrects (#1439)
    • Météo des services :
      • Ajout d'un nouveau helper internal-link dans les tuiles de Météo, permettant d'insérer des liens redirigeant vers d'autres vues de Canopsis (#1792)